[Plone-IT] come si aggiorna Plone con le sue eggs?

Luca Fabbri keul a redturtle.it
Ven 24 Apr 2015 09:49:27 UTC


2015-04-24 11:08 GMT+02:00 Michele Mordenti <michele.mordenti a gmail.com>:
>
> > Il giorno 23/apr/2015, alle ore 13:24, Luca Fabbri <luca.fabbri a redturtle.it> ha scritto:
> >
> > In ZMI ti dice la versione del prodotto quando lo hai installato la prima volta, oppure quando lo hai reinstallato (cosa che normalmente non dovresti fare ma "shit happens").
>
> Perdonami ma continuo a non capirne la logica, poi non  detto che
> debba per forza capirla, sono semplicemente curioso.
>
> In base a quello che hai scritto perch quando aggiorno
> "collective.tablepage" via Plone dalla 0.4 alla 0.10.1 poi in ZMI
> vedo Version at Install time = 0.10.1?


Ma non  che lo hai reinstallato?
Ti dico cosa vedo in due clienti che hanno montato una vecchia
versione ed ora hanno la 0.10.1:


Pagina con Tabella 0.5b3 0.10.1

...e...

Pagina con Tabella 0.8a1 0.10.1


> Devo pensare ad un errore del prodotto? Conosco personalmente lo
> sviluppatore, fidati che  uno di quelli bravi :-)
>

Possibile, lo sviluppatore  un noto minchione, non fidarti.


> > Gli aggiornamenti di prodotti (se il prodotto  ben fatto) sono da fare da interfaccia Plone.
>
> Si, ma nella documentazione c' scritto
> "Navigate to the quickinstaller in the ZMI, and reinstall or ..."
> A chi devo credere?
>

Io direi che la documentazione  sbagliata, o andrebbe sviluppata
meglio del tipo "se proprio hai delle sfighe o il prodotto non
presenta upgrade step, reinstalla e prega"


> > Poi ci sono eccezioni e problemi possono capitare, ma  tutto qui.
> Certamente, non pretendo che tutto sia esente da errori.
> E' solo che prima di avere noie con il prodotto, e ti assicuro che
> quando ti si rompe la tinyMCE ne hai un bel po', vorrei fare le cose
> nel modo pi pulito possibile per evitare di perdere un sacco di tempo
> dopo nel raccogliere i cocci.
> Ad esempio ora mi trovo istanze con temi grafici derivati dal vecchio
> SunBurst con questo nel portal setup:
> The profile "plonetheme.sunburst:default" is currently upgraded to version 2.
> The filesystem version for the "plonetheme.sunburst:default" profile
> is currently 3.
> Upgrade to plonetheme.sunburst 1.4 Migrate to plonetheme.sunburst with
> seperated styles and register new reset.css. (2 → 3)
>
> Che faccio?
> Non ho idea di cosa faccia quell'affare e non lo voglio sapere.
> Poi posso anche attaccarmi al motto "if it works don't fix it" quindi
> non farmi troppe paranoie su quanto indicato nel quickinstaller/portal
> setup-upgrade
>

Su questo hai ragione, c' un problema noto di aggiornamento di
TinyMCE tra la 4.2 e la 4.3 che ha colpito molte persone

Il problema  che non hai modo di sapere che cosa fatto quegli upgrade
step se non guardando nel codice... tendenzialmente quando me li trovo
in interfaccia Plone mi sento "abbastanza" sicuro ma ovviamente non
faccio nulla direttamente in produzione.





-- 
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: luca.fabbri a redturtle.it
Web Site: http://www.redturtle.it/
Phone: +39 0532 1915958
Fax: +39 0532 287070


Maggiori informazioni sulla lista Plone-IT