[Plone-IT] LinguaPlone e il "languageindipendent" che non si aggiorna

Luca Fabbri keul a redturtle.it
Mar 4 Nov 2014 08:39:57 UTC


2014-11-04 9:28 GMT+01:00 Vito Falco <vitofalco a gmail.com>:
> Ciao,
> su un sito fatto un po' di tempo fa (plone 4), dove ho scritto dei
> contentypes custom e usato linguaplone (4.1.3) per la gestione delle
> versioni in lingua, ho scovato un comportamento anomalo.
>
> Il contenttype ha vari campi di vario tipo stringa / immagine / file, tra i
> quali uno  stato settato come
> languageindipendent = True
>
> per l'esattezza
> atapi.StringField('sitostruttura',
>                              languageIndependent=True,
>                              required=False,
>                              validators = ('isURL',),
>                              widget = atapi.StringWidget(
>                              label = _(u'label_struttura_sito',
> default=u'Sito web'),
>                                  )),
>
> Tale campo quando aggiornato non "riflette" le modifiche sulle altre lingue,
> ovvero se come "sitostruttura" era impostato il valore di "www.google.it",
> aggiornandolo a "www.sitochevuoi.it" nella versione "orginale" viene
> sitochevuoi.it mentre nelle altre lingua rimane google.it
>
> Non so che pesci pigliare, qualcuno ha idea?
> Vito
>


Non mi  mai capitato.

Ma la discrepanza la vedi proprio nella vista del contenuto? Andando a
visitare la traduzione vedi il vecchio valore?


-- 
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: luca.fabbri a redturtle.it
Web Site: http://www.redturtle.it/
Phone: +39 0532 1915958
Fax: +39 0532 287070


Maggiori informazioni sulla lista Plone-IT