[Plone-IT] LinguaPlone e il "languageindipendent" che non si aggiorna

Vito Falco vitofalco a gmail.com
Mar 4 Nov 2014 08:28:44 UTC


Ciao,
su un sito fatto un po' di tempo fa (plone 4), dove ho scritto dei
contentypes custom e usato linguaplone (4.1.3) per la gestione delle
versioni in lingua, ho scovato un comportamento anomalo.

Il contenttype ha vari campi di vario tipo stringa / immagine / file, tra i
quali uno  stato settato come
languageindipendent = True

per l'esattezza
atapi.StringField('sitostruttura',
                             languageIndependent=True,
                             required=False,
                             validators = ('isURL',),
                             widget = atapi.StringWidget(
                             label = _(u'label_struttura_sito',
default=u'Sito web'),
                                 )),

Tale campo quando aggiornato non "riflette" le modifiche sulle altre
lingue, ovvero se come "sitostruttura" era impostato il valore di "
www.google.it", aggiornandolo a "www.sitochevuoi.it" nella versione
"orginale" viene sitochevuoi.it mentre nelle altre lingua rimane google.it

Non so che pesci pigliare, qualcuno ha idea?
Vito

-- 
*Vito Falco*
Designer & Front-end developer | Plone consultant | Freelance
Bari, IT
tel +39 3346330137 | skype vito80ba | twitter vito80ba
Linkedin http://it.linkedin.com/in/vitof
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.plone.org/pipermail/plone-plone-it/attachments/20141104/9936764e/attachment.html>


Maggiori informazioni sulla lista Plone-IT