[Plone-IT] Esperimenti con Zope/Plone: HTML tal quale.

Michele Mordenti michele.mordenti a gmail.com
Mar 30 Apr 2013 12:49:23 UTC


Questa mattina mi sono posto la semplice domanda:
come faccio a servire pagine html statiche con Zope/Plone?

Non mi serviva scrivere un prodotto per Plone come
http://developer.plone.org/getstarted/helloworld/

ma proprio servire qualcosa di minimale tipo un helloWorld.html:

<html><body><h1>Hello World</h1></body></html>

in fondo Zope Ŕ un web server.

Google mi porta qui:
http://quintagroup.com/services/support/zope-development/index_html#html

Ho quindi iniziato a paciugare con ZMI e WebDav scoprendo 'cose' strane.

Esperimento1:
Copio il file helloWorld.html sulla root di Zope.

Risultato:
Invocando la risorsa questa viene servita "tal quale".

La stesso esperimento "dentro" un ID Plone da risultati diversi.
Copiando il file via Webdav questo viene in qualche modo "frullato" e
diviene una risorsa di Plone: viene indicizzato, reso privato e servito con
il tipico contorno Plonesco.
Ottimo se voglio fare import massivo di contenuti dentro Plone, ma io
volevo qualcosa di decisamente diverso: servire la risorsa "tal quale".

Ho usato WebDav per caricare inizialmente la struttura (files e folders)
nella root del sito. Poi via ZMI ho fatto un taglia/incolla della risorsa
dalla radice di Zope all'interno della istanza Plone.
Anche un clear and rebuild del portal catalog ha completamente ignorato la
risorsa.

Questo il risultato:
istanza Plone http://nettuno.comune.imola.bo.it/ploneGovIt
e oggetto alieno al CMS e servito tal quale.
http://nettuno.comune.imola.bo.it/ploneGovIt/2013wpd_micmord/index.html


Ok, ho scritto banalitÓ, ma io 'ste cose mica le sapevo :-)

-- 
Michele Mordenti
-------------- parte successiva --------------
Un allegato HTML Ŕ stato rimosso...
URL: <http://lists.plone.org/pipermail/plone-plone-it/attachments/20130430/e0562f1a/attachment.html>


Maggiori informazioni sulla lista Plone-IT