[Plone-IT] export workflow

Riccardo Lemmi riccardo a reflab.com
Lun 16 Gen 2012 11:19:04 UTC


On Monday 16 January 2012, Alex Sani wrote:
> Ciao a tutti, avrei un problema nella creazione di un workflow in un
> prodotto.
> In particolare il workflow creato deve gestire dei gruppi legati a dei
> ruoli.
> Quello che ho fatto, dopo aver creato il workflow,  di esportarlo dal
> portal_setup e di inserirlo nel prodotto.
> 
> Il problema  che quando installo il prodotto,il workflow viene creato, i
> ruoli vengono creati correttamente ma non vengono inseriti i gruppi.
> Effettivamente aprendo l'xml non c'e' nessuna sezione per la
> l'inizializzazione della gestione dei gruppi.
> 
> La cosa strana  che vengono esportati le associazioni gruppo->ruolo
> infatti aggiungendo i gruppi manualmente, le associazioni nei vari stati
> vengono assegnate correttamente com'era il workflow originale creato.
> 
> Qualcuno mi puo' dare una mano?  un bug?
> 
> Grazie
> Alex

I gruppi vanno creati con uno script (un setup handler) in quanto stanno 
dentro acl_users e questo tool non esporta la configurazione.

-- 
Riccardo Lemmi
ber Developer
Reflab - helping humanitarian action through web innovation
phone +39 050 8665414 - fax +39 050 8665478
http://www.reflab.com
-------------- parte successiva --------------
Un allegato non testuale  stato rimosso....
Nome:        signature.asc
Tipo:        application/pgp-signature
Dimensione:  198 bytes
Descrizione: This is a digitally signed message part.
URL:         <http://lists.plone.org/pipermail/plone-plone-it/attachments/20120116/7a70f691/attachment.asc>


Maggiori informazioni sulla lista Plone-IT