[Plone-IT] Collage e gallery-collage-view: AttributeError: 'SimpleViewClass from ..../eggs/Pro' object has no attribute 'title'

Alessandro Pisa alessandro.pisa a gmail.com
Ven 3 Ago 2012 16:15:57 UTC


2012/8/3 Federico Bruni <fedelogy a gmail.com>:
> Il 03 agosto 2012 10:05, Alessandro Pisa <alessandro.pisa a gmail.com> ha scritto:
>> 2012/8/2 Federico Bruni <fedelogy a gmail.com>:
>>> Il 02 agosto 2012 13:53, Luca Fabbri <keul a redturtle.it> ha scritto:
>>>> Fissalo nel versions, come facevi prima, poi rifai il bootstrap con
>>>> l'opzione "-v 1.5.2". Dovrebbe sistemare!
>>>
>>> ah ok.... avevo provato quel comando in una directory con un buildout.cfg vuoto
>>>
>>> ho dovuto mettere il versions all'inizio (e non alla fine) del buildout:
>>>
>>> [buildout]
>>> [versions]
>>> zc.buildout = 1.5.2
>>>
>>
>> Immagino che tra [buildout] e [versions] ci siano anche altre righe, vero?
>> Altrimenti tutto cio' che definisci nella sezione [buildout] viene perso.
>>
>
> Come ho scritto, l'avevo messo all'inizio perché altrimenti ottenevo
> questo errore:
>  ValueError: ('Missing distribution spec', '=')
>
> Ora l'ho riportato in fondo e ho un nuovo errore:
>
> $ ./bin/buildout -vv
> Installing 'buildout.dumppickedversions'.
> We have the distribution that satisfies 'buildout.dumppickedversions==0.5'.
> While:
>   Installing.
>   Loading extensions.
> Error: There is a version conflict.
> We already have: distribute 0.6.28
>

Stai usando virtualenv? Probabilmente distribute 0.6.28 e' installato
a livello di sistema e va in conflitto con quello che hai specificato
qua:
 - http://dist.plone.org/release/4.2-latest/versions.cfg
ovvero il 0.6.27.
O usi il virtualenv o aggiungi nella sezione [versions] la versione
che usi di sistema:
 - distribute = 0.6.28

Il fatto che ti dicesse
 - ValueError: ('Missing distribution spec', '=')
mi fa pensare ad un errore di sintassi.

Ciao!
-- 
http://alepisa.blogspot.com
Esalando Prassi


Maggiori informazioni sulla lista Plone-IT