[Plone-IT] errore nell'accesso ad un tipo di oggetto

Yuri yurj a alfa.it
Mar 29 Nov 2011 09:40:23 UTC


Il 29/11/2011 10:10, Francesco Benincasa ha scritto:
> Ciao a tutti,
> da qualche giorno non riesco a venire a capo di un problema che sembra una
> stupidata.
>
> Gli oggetti di un certo tipo danno errore se si tenta di visualizzarli.
> Esempio, sono in una folder e vedo la lista di oggetti, se clicco su uno di
> essi mi da:

Sono folderish. Sono stati importati? C' stato un upgrade? Google che 
dice? :)

> *************************************
> 2011-11-29T09:27:07 ERROR Zope.SiteErrorLog 1322555227.790.902085089381 http://127.0.0.1:8082/Plone/folder/oggetto
> Traceback (innermost last):
>    Module ZPublisher.Publish, line 115, in publish
>    Module ZPublisher.BaseRequest, line 437, in traverse
>    Module Products.CMFCore.DynamicType, line 150, in __before_publishing_traverse__
>    Module Products.CMFDynamicViewFTI.fti, line 215, in queryMethodID
>    Module Products.CMFDynamicViewFTI.fti, line 182, in defaultView
>    Module Products.CMFPlone.PloneTool, line 827, in browserDefault
>    Module plone.app.folder.base, line 65, in index_html
>    Module plone.folder.ordered, line 202, in __contains__
> TypeError: argument of type 'NoneType' is not iterable
> *************************************
>
> Se accodo la stringa "/view" alla URL l'oggetto viene visualizzato
> correttamente.
>
> Ho pensato fosse qualche problema con la vista di default, ma nell'xml del
> tipo sembra tutto ok, "immediate_view" e' settata, "view_methods" anche, ed
> anche la action view:
>    <action title="View"
>            action_id="view"
>            category="object"
>            condition_expr=""
>            url_expr="string:${object_url}/view"
>            visible="True">
>      <permission value="View" />
>    </action>
>
> Da cosa puo' dipendere? Avete qualche idea?
> Grazie.
>



Maggiori informazioni sulla lista Plone-IT