[Plone-IT] Installazione di Plone su Lion

Luca Fabbri luca a keul.it
Ven 11 Nov 2011 17:05:10 UTC


Molti risolvono i problemi legati a Python (soprattutto su MacOS) non
usando un Python installato manualmente ma tramite questo buildout:
http://svn.plone.org/svn/collective/buildout/python/

On Fri, Nov 11, 2011 at 5:48 PM, Giampiero Lago <lago a tigem.it> wrote:
> Salve ragazzi,
>
> sono Giampiero, da qualche tempo utilizzo Plone, un po' di tempo fa vi ho
> scritto un post perche' avevo un problema ad installare Plone su MacOS X
> 10.7. ma non ho ricevuto nessuna risposta, ve lo ripropongo:
> Ho provato l'installazione con il .pkg ma mi fallisce; allora l'ho
> installato tramite sorgenti eseguendo queste operazioni:
>
> 1) ho scaricato ed installato il dmg di Python 2.6 dal sito python.org e
> l'ho installato tramite il pkg
> 2) ho scaricato ed installato easy_install con il comando python2.6
> ez_setup.py
> 3) ho ripristinato l'easy_install per python 2.7 di sistema
>    cd /usr/bin
>    rm easy_install
>    ln -s easy_install-2.4 easy_install
> 4) ho installato ZopeSkel con il comando easy_install-2.6 ZopeSkel==2.21.2
> 5) ho scaricato ed installato il PIL 1.1.7
>    wget http://effbot.org/downloads/Imaging-1.1.7.tar.gz
>    tar xvfz Imaging-1.1.7.tar.gz
>    cd Imaging-1.1.7
>    python2.6 setup.py install
> 6) ho creato l;istanza con il comando paster create -t plone4_buildout
> 7) ho eseguito il bootstrap.py con il comando python2.6 bootstrap.py
> 8) ho eseguito il buildout con il comando ./bin/buildout -nvvvv
>
> e mi da il seguente errore:
>
> Installing 'mr.developer', 'buildout.dumppickedversions'.
> We have no distributions for mr.developer that satisfies
> 'mr.developer==1.17'.
> Getting distribution for 'mr.developer==1.17'.
> Running easy_install:
> /usr/bin/python2.6 "-c" "from setuptools.command.easy_install import main;
> main()" "-mUNxd" "/Users/lago/Plone/devel/eggs/tmpkZjTqr" "-v"
> "/tmp/tmp60Uy71get_dist/mr.developer-1.17.zip"
> path=/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python
>
> Traceback (most recent call last):
>  File "<string>", line 1, in <module>
> ImportError: No module named setuptools.command.easy_install
> An error occured when trying to install mr.developer 1.17. Look above this
> message for any errors that were output by easy_install.
> While:
>  Installing.
>  Loading extensions.
>  Getting distribution for 'mr.developer==1.17'.
> Error: Couldn't install: mr.developer 1.17
>
> Questo errore me lo dava anche sul portatile ma me lo hanno corretto (mi
> ricordo che era qualcosa legato a dove era installato easy_install) adesso
> sto provando sul fisso ma non mi ricordo come hanno fatto a risolvere il
> problema.
>
> Grazie
>
> Giampiero
>
>
> --
> Giampiero Lago
> Web Area Manager - IT Core
> TIGEM (Telethon Institute of Genetics and Medicine)
> Via P. Castellino, 111
> 80131 - NAPOLI
>
> Direct Phone:           +39 081 6132337
> Secretariat Phone:      +39 081 6132200
> Fax:                    +39 081 5609877
> E-mail:                 lago a tigem.it
>
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-plone-it
> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
>



-- 
-- luca

twitter: http://twitter.com/keul
linkedin: http://linkedin.com/in/lucafbb
blog: http://blog.keul.it/


Maggiori informazioni sulla lista Plone-IT