[Plone-IT] ldap plone 4.1 centos 6

Lorenzo Cipriani cipriani.lore a gmail.com
Ven 11 Nov 2011 08:36:04 UTC


ho installato numpy (yum installl numpy) ma l'errore Ť sempre li:
*Running easy_install:
/usr/bin/python "-c" "from setuptools.command.easy_install import main;
main()" "-mUNxd" "/opt/buildout/portale_prvpo/eggs/tmpVbGpTZ" "-v"
"/usr/lib/python2.6/site-packages"
path=/opt/buildout/portale_prvpo/eggs/distribute-0.6.19-py2.6.egg*
*Processing site-packages
Running numpy/setup.py bdist_egg --dist-dir
/usr/lib/python2.6/site-packages/numpy/egg-dist-tmp-Y3HlFr
This is the wrong setup.py file to run
No eggs found in /usr/lib/python2.6/site-packages/numpy/egg-dist-tmp-Y3HlFr
(setup script problem?)
While:
  Installing instance.
  Getting distribution for 'python-ldap==2.3.10'.
Error: Couldn't install: python-ldap 2.3.10
*
ho provato a cambiera la versione nel [version] a python-ldap==2.3.13

e l'errore sembra cambiare bo ci sto perdendo la testa....

*Modules/LDAPObject.c:1227: error: ‚LDAP_SUCCESS‚ undeclared (first use in
this function)
Modules/LDAPObject.c:1228: error: ‚LDAPObject‚ has no member named ‚ldap‚
Modules/LDAPObject.c:1185: warning: unused variable ‚newpw‚
Modules/LDAPObject.c:1183: warning: unused variable ‚oldpw‚
Modules/LDAPObject.c:1181: warning: unused variable ‚user‚
error: Setup script exited with error: command 'gcc' failed with exit
status 1
An error occured when trying to install python-ldap 2.3.13. Look above this
message for any errors that were output by easy_install.
While:
  Installing instance.
  Getting distribution for 'python-ldap==2.3.13'.
Error: Couldn't install: python-ldap 2.3.13
*

Il giorno 11 novembre 2011 08:59, Lorenzo Cipriani
<cipriani.lore a gmail.com>ha scritto:

> ciao, ho fatto il buildout aggiungendo l'opzione -vvv  (sempre da root)
>
> ed ecco il log dove da errore:
>
> *
> Getting distribution for 'python-ldap==2.3.10'.
> Running easy_install:
> /usr/bin/python "-c" "from setuptools.command.easy_install import main;
> main()" "-mUNxd" "/opt/buildout/portale_prvpo/eggs/tmpQoFxat" "-v"
> "/usr/lib/python2.6/site-packages"
> path=/opt/buildout/portale_prvpo/eggs/distribute-0.6.19-py2.6.egg*
> *Processing site-packages
> Running numpy/setup.py bdist_egg --dist-dir
> /usr/lib/python2.6/site-packages/numpy/egg-dist-tmp-5sjgqZ
>
> This is the wrong setup.py file to run
> No eggs found in
> /usr/lib/python2.6/site-packages/numpy/egg-dist-tmp-5sjgqZ (setup script
> problem?)
>
> While:
>   Installing instance.
>   Getting distribution for 'python-ldap==2.3.10'.
> Error: Couldn't install: python-ldap 2.3.10
> *
>
> Il giorno 11 novembre 2011 08:39, Yuri <yurj a alfa.it> ha scritto:
>
> Il 11/11/2011 08:32, Lorenzo Cipriani ha scritto:
>>
>>> Grazie mille per la risposta... ho lanciato il buildout come utente root
>>> ma l'errore Ť senmpre li (anche se diverso)
>>> *Getting distribution for 'python-ldap==2.3.10'.
>>> This is the wrong setup.py file to run
>>> No eggs found in /usr/lib/python2.6/site-**packages/numpy/egg-dist-tmp-*
>>> *Af9Tkj (set up script problem?)
>>> While:
>>>  Installing instance.
>>>  Getting distribution for 'python-ldap==2.3.10'.
>>> Error: Couldn't install: python-ldap 2.3.10
>>> *
>>> grazie a chiunque per l'aiuto...
>>>
>>
>> Lancia il buildout aggiungendo l'opzione -vvv in modo da vedere tutti i
>> messaggi.
>>
>> Per compilare, credo abbia bisogno di alcune librerie, dal web ho trovato
>> questo:
>>
>> http://plone.293351.n2.nabble.**com/Plone-3-3-buildout-errors-**
>> in-getting-python-ldap-**td3494049.html<http://plone.293351.n2.nabble.com/Plone-3-3-buildout-errors-in-getting-python-ldap-td3494049.html>
>>
>> e dice:
>>
>> # apt-get install libsasl2-dev libcrypto++-dev libldap2-dev libssl-dev
>>
>> Forse ti mancano le librerie richieste.
>>
>>
>> Il giorno 10 novembre 2011 17:49, Fabrizio Reale <
>>> fabrizio.reale a redomino.com <mailto:fabrizio.reale@**redomino.com<fabrizio.reale a redomino.com>>>
>>> ha scritto:
>>>
>>>
>>>    Ciao Lorenzo,
>>>
>>>    In data giovedž 10 novembre 2011 17:34:52, Lorenzo Cipriani ha
>>>    scritto:
>>>    > Salve a tutti, ho provato ad installare ldap con plone 4.1 su
>>>    una Centos 6
>>>    > (ho installato anche i pacchetti necessari
>>>    >
>>>    > db4-devel, cyrus-sasl-devel, openssl-devel)
>>>    > Purtroppo mi si blocca sempre qui:
>>>    >
>>>    > *Getting distribution for 'python-ldap==2.3.10'.
>>>    > error: /usr/lib/python2.6/site-**packages/numpy/egg-dist-tmp-**
>>> gXGwPp:
>>>    > Permission denied
>>>
>>>    Sei sicuro che l'utente con cui lanci il buildout abbia i permessi
>>>    di scrivere
>>>    in:
>>>     /usr/lib/python2.6/site-**packages/
>>>    ?
>>>
>>>    A presto,
>>>    Fabrizio
>>>
>>>
>>>
>>>    --
>>>    Fabrizio Reale
>>>    Chief Technology Officer
>>>    http://linkedin.com/in/**fabrizioreale<http://linkedin.com/in/fabrizioreale>
>>>
>>>    Redomino Srl
>>>    http://redomino.com <http://redomino.com/>
>>>
>>>    HQ Largo Valgioie 14, Turin IT
>>>    Phone +39 0117499875 <tel:%2B39%200117499875>
>>>
>>>
>>>
>>> ______________________________**_________________
>>> Plone-IT mailing list
>>> Plone-IT a lists.plone.org
>>> https://lists.plone.org/**mailman/listinfo/plone-plone-**it<https://lists.plone.org/mailman/listinfo/plone-plone-it>
>>> http://plone-regional-forums.**221720.n2.nabble.com/Plone-**
>>> Italy-f221721.html<http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html>
>>>
>>
>> ______________________________**_________________
>> Plone-IT mailing list
>> Plone-IT a lists.plone.org
>> https://lists.plone.org/**mailman/listinfo/plone-plone-**it<https://lists.plone.org/mailman/listinfo/plone-plone-it>
>> http://plone-regional-forums.**221720.n2.nabble.com/Plone-**
>> Italy-f221721.html<http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html>
>>
>
>
-------------- parte successiva --------------
Un allegato HTML Ť stato rimosso...
URL: <http://lists.plone.org/pipermail/plone-plone-it/attachments/20111111/8fad6b24/attachment-0001.html>


Maggiori informazioni sulla lista Plone-IT