[Plone-IT] R: R: Plone Hotfix 20110622 e zeocluster

Lorenzo Maurizi - CELFI lorenzo.maurizi a unimc.it
Mer 29 Giu 2011 11:07:02 UTC


" This is particularly likely if you try to use
Buildout with Plone 3 or Plone 3.1."

Mi parlavi di Plone 4.0.7 quindi già è un punto a favore.
Io ho effettuato l'aggiornamento su un Plone 4.0.5 installato su uno
zeocluster (2 client + zeoserver) senza problemi.
Credo (ma non sono un super esperto) che la soluzione sia "pinnare" le
versioni sul buildout per evitare di scaricare le versioni più nuove dei
prodotti python quando si rilancia la creazione del buildout.
Se il tuo buildout prevede il pin delle versioni, allora vai tranquillo.

Se l'installazione di Plone è basata su buildout (e con Plone 4.0.7 non
credo si possa fare altrimenti) non puoi usare l'installazione stile unzip
del file nella cartella Products, perché quando rilanci per qualche motivo
il buildout, questa cartella viene cancellata e ricreata da capo, e allora
perderesti l'hotfix installato a mano.

Ciao da Lorenzo


-----Messaggio originale-----
Da: plone-plone-it-bounces a lists.plone.org
[mailto:plone-plone-it-bounces a lists.plone.org] Per conto di luigi scarso
Inviato: mercoledì 29 giugno 2011 12.56
A: La lista degli italiani appassionati di Plone.
Oggetto: Re: [Plone-IT] R: Plone Hotfix 20110622 e zeocluster

2011/6/29 Lorenzo Maurizi - CELFI <lorenzo.maurizi a unimc.it>:
> Ciao Luigi,
> provo a risponderti rapidamente.
>
> Nel caso di zeocluster, devi inserire la hotfix come egg nel buildout come
> specificato, in modo da rigenerare anche i vari client, poi per vedere che
> la Hotfix sia stata caricata, basta che ti guardi il file log del client
> dentro la cartella
> {buildout-dir}/var/log
> e cerchi la riga
> INFO Zope_Hotfix_20110622 Hotfix installed.
>
> Di solito il file si chiama come il client (client1.log, client2.log etc).
> Non aprire i files che si chiamano clientX-Z2.log che quelli sono i log
http
> degli accessi allo Zope http server.
>
> Ciao da Lorenzo
OK, grazie.  In pratica è

Installing with Buildout
If you are an experienced Plone administrator, and you are using a
Buildout-based installation of Plone, you may choose to install Hotfix
20110622 with Buildout. However, if you choose to do this, you must be
certain that you will not accidentally overwrite Plone components with
newer versions.  This is particularly likely if you try to use
Buildout with Plone 3 or Plone 3.1.
If you are not sure what you're doing, please use the "Recommended
Installation Instructions" above.

Non è sconsigliato, ma
"However, if you choose to do this, you must be certain that you will
not accidentally overwrite Plone components with newer versions"
non mette a proprio agio.

Come per Yuri, scusa la pedanteria. Lo scopo è discuterne un po'.

-- 
luigi
_______________________________________________
Plone-IT mailing list
Plone-IT a lists.plone.org
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



Maggiori informazioni sulla lista Plone-IT