[Plone-IT] python:toLocalizedTime e localTimeFormat - la configurazione non funziona

Diego Purpo diego.purpo a infocube.it
Mer 3 Ago 2011 08:37:16 UTC


Grazie Luca.
Aggiungo alla lista di componenti utili :D

On 03/08/2011 10:32, Luca Fabbri wrote:
> 2011/8/3 Diego Purpo<diego.purpo a infocube.it>:
>> Grazie Luca.
>>
>> Ho fatto un po' di reverse ed è proprio come dici tu.
>> C'è un if bello chiaro sul risultato della traduzione: se vuota utilizza il
>> config delle site_properties.
>>
>> Per adesso ho risolto così, importando il modulo DateTime, poichè non ho
>> particolari necessità di presentazione in varie lingue:
>>
>> <tal:show_date tal:define="DateTime python:modules['DateTime'].DateTime;"
>> tal:content="python:DateTime(date).strftime('%d/%m/%Y')" />
> Qualche giorno fa abbiamo sviluppato questo prodotto proprio per
> risolvere problemi legati all'uso di strftime, che usato in Plone non
> è "il modo corretto" (troverai la discussione sulla lista inglese
> Plone-Users):
> http://pypi.python.org/pypi/experimental.ulocalized_time/
>
> Se in futuro ti dovesse capitare di avere questa necessita in un sito
> multilingua... :-)
>
>


-- 

*Diego Purpo*
cel. +39 393 9869631
diego.purpo a infocube.it <mailto:diego.purpo a infocube.it>

*INFOCUBE srl*
via gino doria, 84 | 80128 napoli
tel. +39 081 3412051 | fax. +39 081 19305669
p.iva 05808481211 | c.f. 05808481211 | rea NA 0777171
www.infocube.it <http://www.infocube.it>
blog.infocube.it <http://blog.infocube.it>

-------------- parte successiva --------------
Un allegato HTML è stato rimosso...
URL: <http://lists.plone.org/pipermail/plone-plone-it/attachments/20110803/6b24a257/attachment.html>


Maggiori informazioni sulla lista Plone-IT