[Plone-IT] problema visualizzazione sito importato mediante file .zexp

swiftbrooke lucab a diecidieci.com
Mer 14 Apr 2010 15:27:04 UTC


Salve, 

ieri ho completato con successo la mia prima installazione di zope e plone.
Successivamente ho provato ad importare un sito gia basato su plone ed
esportato in formato .zexp. La procedura di importazione, effettuata dalla
zmi, Ŕ stata completata con successo, ma se provo ad accedere al sito
importato ottengo i seguenti errori:

*////////////////////////////////////////////////////////////////*
Site Error

An error was encountered while publishing this resource.

ComponentLookupError
(Also, the following error occurred while attempting to render the standard
error message, please see the event log for full details:
renderAllTheScripts)Traceback (innermost last): Module ZPublisher.Publish,
line 202, in publish_module_standard Module ZPublisher.Publish, line 150, in
publish Module plone.app.linkintegrity.monkey, line 21, in
zpublisher_exception_hook_wrapper Module Zope2.App.startup, line 221, in
zpublisher_exception_hook Module ZPublisher.Publish, line 119, in publish
Module ZPublisher.mapply, line 88, in mapply Module ZPublisher.Publish, line
42, in call_object Module Shared.DC.Scripts.Bindings, line 313, in __call__
Module Shared.DC.Scripts.Bindings, line 350, in _bindAndExec Module
Products.CMFCore.FSPageTemplate, line 216, in _exec Module
Products.CMFCore.FSPageTemplate, line 155, in pt_render Module
Products.PageTemplates.PageTemplate, line 98, in pt_render Module
zope.pagetemplate.pagetemplate, line 117, in pt_render - Warning: Macro
expansion failed - Warning: exceptions.AttributeError: renderAllTheScripts
Module zope.tal.talinterpreter, line 271, in __call__ Module
zope.tal.talinterpreter, line 346, in interpret Module
zope.tal.talinterpreter, line 891, in do_useMacro Module
zope.tal.talinterpreter, line 346, in interpret Module
zope.tal.talinterpreter, line 536, in do_optTag_tal Module
zope.tal.talinterpreter, line 521, in do_optTag Module
zope.tal.talinterpreter, line 516, in no_tag Module zope.tal.talinterpreter,
line 346, in interpret Module zope.tal.talinterpreter, line 891, in
do_useMacro Module zope.tal.talinterpreter, line 346, in interpret Module
zope.tal.talinterpreter, line 586, in do_setLocal_tal Module
zope.tales.tales, line 696, in evaluate - URL:
file:/usr/local/Plone/buildout-cache/eggs/Plone-3.3.5-py2.4.egg/Products/CMFPlone/skins/plone_templates/global_defines.pt
- Line 8, Column 0 - Expression: - Names: {'container': , 'context': ,
'default': , 'here': , 'loop': {}, 'nothing': None, 'options': {'args': ()},
'repeat': , 'request': , 'root': , 'template': , 'traverse_subpath': [],
'user': } Module zope.tales.expressions, line 217, in __call__ Module
Products.PageTemplates.Expressions, line 163, in _eval Module
Products.PageTemplates.Expressions, line 125, in render Module
Products.CMFPlone.browser.ploneview, line 74, in globalize Module
Products.CMFPlone.browser.ploneview, line 139, in _initializeData Module
Products.CMFPlone.browser.ploneview, line 527, in have_portlets Module
zope.component._api, line 207, in getUtility ComponentLookupError: (see
above)

Troubleshooting Suggestions

    * The URL may be incorrect.
    * The parameters passed to this resource may be incorrect.
    * A resource that this resource relies on may be encountering an error.

For more detailed information about the error, please refer to the error
log.

If the error persists please contact the site maintainer. Thank you for your
patience
*////////////////////////////////////////////////////////////////*

Potrebbe essere un problema di versioni diverse di plone? Oppure di
funzionalitÓ aggiuntive presenti nella installazione originale di plone e
non in quella che ho eseguito io?

Grazie mille e buon pomeriggio

Luca
-- 
View this message in context: http://n2.nabble.com/problema-visualizzazione-sito-importato-mediante-file-zexp-tp4902300p4902300.html
Sent from the Plone - Italy mailing list archive at Nabble.com.




Maggiori informazioni sulla lista Plone-IT