[Plone-IT] Nuovo workflow. Anonimo non vede contenuti Pubblicati.

Fabrizio Reale fabrizio.reale a redomino.com
Mer 10 Giu 2009 12:31:30 UTC


Ciao Francesco,

> Ho creato due nuovi workflow, uno per i contenuti generici e uno per le
> cartelle, copiati rispettivamente da altri due workflow perfettamente
> funzionanti (a loro volta copiati da quelli standard di plone
> public_workflow e folder_workflow). 
> I nuovi workflow non fanno altro che aggiungere un nuovo stato e due
> transizioni per raggiungerlo.
> Il workflow per le cartelle sembra funzionare correttamente, mentre
> nell'altro l'utente anonimo non riesce a vedere i contenuti in stato
> "published"!!
> Ho impostato il permesso di "View" per l'utente anonimo in tutti i modi
> possibili, sia sullo stato del workflow (Update security settings sempre
> effettuato), sia a livello globale del sito, ma non c' stato niente da
> fare. Cercando di visualizzare una pagina pubblicata come utente anonimo,
> viene mostrata la pagina della richiesta delle credenziali di accesso.
> 
> La versione di Plone  la 2.5(.5 credo), con, tra gli altri, StagingAddOn
> 1.7.1 (magari  importante)
> 
> Sapete dirmi qual  la causa o eventualmente quali soluzioni potrei provare?

Devi configurare anche il permesso "Access contents information" come hai fatto per "View".

Fammi sapere se risolvi.
A presto,
Fabrizio

-- 
Fabrizio Reale

Redomino S.r.l.
Largo Valgioie 14, 
10146 Torino Italy
Tel: +39 0117499875
http://redomino.com




Maggiori informazioni sulla lista Plone-IT