[Plone-IT] solr

Silvio silviot a gmail.com
Mer 16 Dic 2009 17:16:46 UTC


2009/12/16 fabio <elcose a gmail.com>

> incuriosito dalle critiche positive che e' facile da installare, che fa
> tutto lui...
> nel mio caso i risultati delle ricerche fanno scherzi a me
> incompresibili e ve li racconto:
>
> ho una cartella dal nome presenze.
>
> caso 1 ricerca istantanea
> la trova fino a che scrivo presenz se ci metto la e finale il risultato
> della ricerca e' nessun risultato. questo succede random per altri oggetti.
>
> caso 2 digito presenz e clicco su cerca: 0 risultati (ma come!? la
> ricerca istantanea lo trova)
>
Su solr non ti so dire, ma posso spiegare almeno questo (che succede anche
con un Plone vaniglia): cercando il motivo di questo comportamento con
Firebug ho visto che la ricerca istantanea aggiunge un asterisco alla fine
della stringa se l'ultimo carattere  diverso da spazio.
Quindi quando scrivi "presenz" la ricerca istantanea  su "presenz*" che fa
un match parziale di inizio parola. L'idea  che l'ultima parola  ancora
incompleta durante la battitura.
Probabilmente c' in solr qualche "presenziano" "presenziare" "presenza"
etc, ma non "presenze".
Dici di avere una cartella dal *nome* "presenze". Ha anche il titolo
"Presenze"? (scusa la domanda ovvia: non si sa mai)
Non so pronunciarmi sulle altre questioni: my 2 .

          Silvio

P.S. se risolvi off-list facci sapere cos'era:  un topic interessante che
potrebe capitare ad altri.
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.plone.org/pipermail/plone-plone-it/attachments/20091216/5686067f/attachment.html>


Maggiori informazioni sulla lista Plone-IT