[Plone-IT] Tomcat e Plone sullo stesso server

Gabriele Bavota gabriele.bavota a gmail.com
Mar 14 Apr 2009 08:49:21 UTC


Il giorno 14/apr/09, alle ore 10:40, Luca ha scritto:

> 2009/4/14 Gabriele Bavota <gabriele.bavota a gmail.com>:
>> Vi ringrazio entrambi per la risposta.
>> Per quella di Luigi proverò domani se funziona,
>> per Luca il problema è garantire dall'esterno l'accesso sia al sito  
>> Plone
>> che alle webapps di Tomcat ed entrambi sono sulla porta 80. Non  
>> sono per
>> niente esperto di server e per questo vi sto chiedendo una  
>> mano..:)..quindi
>> se ho detto una boiata ditemelo pure!
>
> Immagino quindi che quando dici "dall'esterno" significhi che il
> vostro server (giustamente!) permetta l'accesso solo sulla porta 80.
> Ciò che ha scritto Luigi quindi ti può tornare utile!
>
> Devi mettere davanti a tutti Apache.
>
> Diciamo per esempio che Tomcat debba girare sulla 8080, Zope/Plone
> sulla 8090 e Apache davanti che redirige il traffico a seconda degli
> URL chiamati.
>
> PS: in realtà credo che tomcat stesso sulla 80 possa fare il mestiere
> che farebbe Apache ma non sono troppo sicuro!... sono passati troppi
> anni però da quando ho utilizzato il buon Java/JSP
>
> Rimane il fatto che la configurazione migliore è Apache sulla 80!
>
> -- 
> -- luca
>
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> http://lists.plone.org/mailman/listinfo/plone-it
> http://www.nabble.com/Plone---Italy-f21728.html

Esatto il problema è proprio quello!
Domani provo la soluzione di Luigi e vi farò sapere!
Grazie e buona giornata!
Gabriele.





Maggiori informazioni sulla lista Plone-IT