[Plone-IT] Re: Plone 3 errori di traduzione

Marco De Vitis starless a spin.it
Dom 1 Giu 2008 14:08:33 UTC


Il 1-06-2008 11:56, Lele Gaifax ha scritto:
> Marco De Vitis <starless a spin.it> writes:
>> Quindi forse, per qualche strano motivo, se sono selezionate lingue
>> diverse dall'inglese questi due .po vengono caricati e "sovrapposti"
>> nell'ordine sbagliato?
> 
> No, i cataloghi di lingue diverse non vengono sovrapposti. Il problema
> sta proprio in quel '''ha lo stesso msgid''' di un'altra entry, una
> delle due ha il sopravvento.

Infatti non parlavo di cataloghi di lingue diverse, parlavo dei due 
diversi cataloghi italiani: quello di ATContentTypes e quello principale 
di Plone; sono questi due che contengono le due stringhe con stesso 
msgid, solo che gli stessi msgid sono presenti nei .pot originali, 
quindi non si capisce perché con il sito in inglese venga presa la 
stringa giusta, mentre in un'altra lingua avvenga questo errore... Per 
questo ipotizzavo che, solo quando il sito è impostato in una lingua 
diversa dall'inglese, venisse caricato prima il plone-xx.po e poi 
l'atcontenttypes-xx.po la cui stringa "sovrascrive" quella giusta del 
primo. Ma è solo un'ipotesi di persona che non sa come vengano gestiti 
internamente i cataloghi da Plone.

>> Immagino sia da segnalare nella lista internazionale.
> 
> Sì, sei iscritto alla lista plone-i18n? Puoi fare tu?

Sì, certo. Non lo avevo fatto perché ricordavo che la seguivi tu stesso. 
Provvedo subito, anche se forse dovrei aprire un bug nel tracker. 
Vediamo che mi dicono.

-- 
Ciao,
   Marco.





Maggiori informazioni sulla lista Plone-IT