[Plone-IT] problema Logout CAS su Plone3

Yuri yurj a alfa.it
Mar 1 Lug 2008 10:40:38 UTC


melapple ha scritto:
> ok, il problema e' automatizzare il tutto.
>   

cancella i cookie di plone quando l'utente fa logout. Quando clicchi su 
logout, vai a uno script. Lý cancelli i cookie.

> melapple wrote:
>   
>> Salve, non so se questo sia un bug o un problema dovuto ad un'istallazione
>> errata :
>> questa la mia procedura:
>> 1. sotto acl_user dell'istanza di Plone3 ho istallato "CASAuthHelper
>> Plugin" l'unico modulo compatibile con plone3
>>
>> 2. qui ho configurato gli url di validazione di cas per il login, logout e
>> ticket
>>
>> 3.Poi ho installato da plone sotto Add/Product "UI for CAS Login (Castle)"
>>
>> A questo punto ho creato un utente che so che esiste nel Db di CAS e da
>> plone quando faccio il login mi reindirizza a CAS e mi logga
>> correttamente, il problema e' quando faccio il logout.
>>
>> Inizilmente il Logout funziona, ma se riseleziono login si rilogga
>> l'utente di prima.Come se e' rimasto in sessione. Sapete se e' un bug del
>> componente? ci sara' modo di forzare il logout correttamente? ovviamente
>> se svuoto i cookie riparte l'autentificazione su CAS. Grazie dell'aiuto.
>>
>>     
>
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> http://lists.plone.org/mailman/listinfo/plone-it
> http://www.nabble.com/Plone---Italy-f21728.html





Maggiori informazioni sulla lista Plone-IT