[Plone-IT] Problemi con Clouseau /Zope debug

Fabrizio Reale fabrizio.reale a redomino.com
Ven 8 Feb 2008 08:17:10 UTC


Alle giovedì 7 febbraio 2008, Michele De Mori ha scritto:
> Mi scuso per la mia ingnoranza in materia, abbiate pazienza e pieta,  ma
> sono un neofita nello sviluppo Plone/Zope.

Tranquillissimo tutti siamo stati neofiti :)

>
> Ho un'installazione Debian Zope/Plone3

Ottima scelta :)

>
> Ho installato Clouseau ma mi da questo errore se tento di usarlo:
>
> *The inspector is not enabled*. There are settings in the file
> /config.py/. If you don't want to read the /readme.txt/ about these
> settings then please note: /By default Clouseau will only be enabled if
> you run Zope with debug-mode turned on/.
>
> Giuro che il file readme.txt lo ho letto :-)
>
> Bene dopo aver capito che il "Zope Inspector" è componente di Clouseau e
> non di Zope, come pensavo ieri  :-)  ( povero me ), ho immaginato che il
> problema fosse l'avvio di Zope in debug che io lanciavo con -D.
> Mi è stato suggerito che non va bene allora ho provato con "zopectl fg"
> ma putroppo si peresenta quanto sotto.
>
> Che sta accadendo ?

Pensa un po' le coincidenze :)
Tu non lo sai ma la quel problema è colpa mia.

>  File "/home/zope/plone3/parts/plone/GenericPloneContent/config.py",
> line 1, in ?
>    from Products.CMFCore.CMFCorePermissions import AddPortalContent
> ImportError: No module named CMFCorePermissions

Il problema non è Clouseau, bensì, come si legge nel TB, di Generic Plone 
Content che purtroppo non è ancora compatibile con Plone 3.
A dir la verità io ne ho una versione che funziona sul 3, ma senza molto test 
e con l'interfaccia un po' da sistemare, ma se vuoi te la passo volentieri 
per test. Poi appena ho tempo la pubblico.

Saluti,
Fabry




-- 
Fabrizio Reale                               fabrizio.reale a redomino.com
Redomino S.r.l.                 Largo Valgioie 14 - 10146 Torino - Italy
Tel: +39 011 7499875 - Fax: +39 011 3716911     http://www.redomino.com/




Maggiori informazioni sulla lista Plone-IT