[Plone-IT] modulo Python non visto dal prodotto che lo richiede

moaiamorfo moaiamorfo a gmail.com
Gio 7 Ago 2008 08:42:47 UTC


> Devi guardare nel file di avvio di Zope dove setta i path. Oppure fai un
> link nella directory lib di zope. Nel modulo da installare dovrebbero
> esserci tutte le istruzioni.
>
> Sei sicuro di aver utilizzato il python di Plone e non quello di sistema per
> installare il modulo?
>
> C' anche questo how-to:
> http://plone.org/documentation/faq/how-do-i-install-python-modules-to-the-unified-installer/
>
> qui c' un esempio di discussione sul topic:
> http://plone.org/support/forums/setup#nabble-td351927|a14355563

grazie Yuri, ecco il contenuto del file zopectl:

#! /bin/sh

PYTHON="/usr/bin/python2.4"
ZOPE_HOME="/usr/lib/zope2.9"
INSTANCE_HOME="/home/user1/istanze/IS-CMS"
CONFIG_FILE="/home/user1/istanze/IS-CMS/etc/zope.conf"
SOFTWARE_HOME="/usr/lib/zope2.9/lib/python"
PYTHONPATH="$SOFTWARE_HOME:$PYTHONPATH"
export PYTHONPATH INSTANCE_HOME SOFTWARE_HOME

ZDCTL="$SOFTWARE_HOME/Zope2/Startup/zopectl.py"

exec "$PYTHON" "$ZDCTL" -C "$CONFIG_FILE" "$@"

il Python indicato  proprio quello presso il quale ho installato il
modulo (infatti se invoco python2.4 e importo il modulo  tutto ok).
cosa dovrei aggiungere qui per inserire un riferimento al modulo (che
ora  installato sotto /usr/lib/python2.4/site-packages)?

grazie ancora.

-- 
Antonio Fittipaldi
http://www.python-it.org # il punto di riferimento italiano per gli
appassionati di Python




Maggiori informazioni sulla lista Plone-IT