[Plone-IT] Problemi con Plone3 e ArchGenXML

Alessandro Trevisan kiwi.alessandro a gmail.com
Gio 6 Set 2007 15:33:36 UTC


Ciao a tutti,
ho recentemente installato Plone 3 su un PC con S.O. Fedora Core 6.

Purtroppo ho 2 problemi che non riesco a risolvere:

il primo riguarda ArchGenXML:
sto leggendo il tutorial presente in plone.org
http://plone.org/documentation/tutorial/archgenxml-getting-started/intro

ho installato la versione 1.6 beta1 utilizzando il python di Plone3
durante l'installazione mi da alcuni errori:

byte-compiling build/bdist.linux-i686/egg/archgenxml/templates/widget.py to
widget.pyc
  File "build/bdist.linux-i686/egg/archgenxml/templates/widget.py", line 12
    from Products.<dtml-var "klass.getPackage().getProduct().getName()">
import config
                  ^
SyntaxError: invalid syntax
byte-compiling build/bdist.linux-i686/egg/archgenxml/templates/view_class.py
to view_class.pyc
  File "build/bdist.linux-i686/egg/archgenxml/templates/view_class.py", line
1
    <dtml-let assocs="klass.getFromAssociations
(aggtypes=['none','aggregation','composite'])"
    ^(...)

poi ancora:
Extracting archgenxml-1.6.b1-py2.4.egg to /opt/Plone-3.0/Python-2.4.4
/lib/python2.4/site-packages
  File "/opt/Plone-3.0/Python-2.4.4/lib/python2.4/site-packages/archgenxml-
1.6.b1-py2.4.egg/archgenxml/templates/widget.py", line 12
    from Products.<dtml-var "klass.getPackage().getProduct().getName()">
import config
                  ^
SyntaxError: invalid syntax
(...)

ma alla fine completa comunque l'installazione.
Poi con Umbrello UML Modeler (1.5.71) creo il content-type esattemente come
spiegato nel tutorial e poi eseguo il comando "archgenxml
nomecontenttype.xmi",
copio la cartella ottenuta in Products e riavvio Plone, installo il prodotto
tramite portal setup/AddRemove products.
Fino  a qui tutto sembra andar bene ma quando vado nella mia cartella
personale non posso aggiungere il content type da me creato (non  presente
nella lista);
se provo ad aggiungerlo dalla ZMI mi appare un messaggio d'errore, se vado a
vedere il log ottengo questo:

Traceback (innermost last):
  Module ZPublisher.Publish, line 119, in publish
  Module ZPublisher.mapply, line 83, in mapply
  Module ZPublisher.Publish, line 47, in missing_name
  Module ZPublisher.HTTPResponse, line 694, in badRequestError
BadRequest:   <h2>Site Error</h2>
  <p>An error was encountered while publishing this resource.
  </p>
  <p><strong>Invalid request</strong></p>

  The parameter, <em>type</em>, was omitted from the request.<p>Make
sure to specify all required parameters, and try the request
again.</p>
  <hr noshade="noshade"/>

  <p>Troubleshooting Suggestions</p>

  <ul>
  <li>The URL may be incorrect.</li>
  <li>The parameters passed to this resource may be incorrect.</li>
  <li>A resource that this resource relies on may be
      encountering an error.</li>
  </ul>

  <p>For more detailed information about the error, please
  refer to the error log.
  </p>

  <p>If the error persists please contact the site maintainer.
  Thank you for your patience.

  </p>

Come posso risolvere il problema?

Il secondo invece riguarda la posta:

in Plone i settaggi della mail sono:
Mail Server:
   SMTP server: localhost
   SMTP port: 25
   ESMTP username e password vuoti
Mail Sender:
   Site 'From' name: luigi
   Site 'From' address : luigi a marcusii

questo  il messaggio di errore in /var/log/maillog:
Sep  6 16:42:24 marcusII sendmail[31760]: l86EgN4V031760: to=<
luigi a marcusII.it>, delay=00:00:01, xdelay=00:00:00, mailer=esmtp,
pri=31818, relay=marcusii.it., dsn=4.0.0, stat=Deferred: Name server:
marcusii.it.: host name lookup failure

questo  il file /etc/hosts:
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1    marcusII    localhost.localdomain    localhost
127.0.0.1 localhost marcusII
192.168.2.84 marcusII.it
192.168.2.84 marcusii.it

Grazie in anticipo
Alessandro
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.plone.org/pipermail/plone-plone-it/attachments/20070906/729e5cec/attachment-0001.html>


Maggiori informazioni sulla lista Plone-IT