[Plone-IT] Cattive nuove da fsrefs.py?

Zanotti Michele Michele.Zanotti a apss.tn.it
Gio 26 Lug 2007 17:17:16 UTC


Cosa succede non lo so. Credo che non sia nulla di grave, seguendo le informazioni che ho raccolto in giro ho provato a fare alcune verifiche ed ho appurato che alcuni degli oggetti nelle  segnalazioni stanno bene. Questo è quanto mi ha risposto Dieter Maurer sulla ZODB-list:

There are buggy "fsref" versions around.
If your Zope 2.8.5 does not show these errors, count the Zope 2.9.7 "fsref" as buggy and file a bug report.
When I remember right, ZODB problems are now handled at "launchpad".

Ancora non ho fatto la segnalazione, perché mi sembrava strano di essere l'unico ad avere il problema. Io in ogni caso ho rimandato il passaggio in produzione alla 2.5.3 finchè non ne so di più. Se fsrefs è un controllo importante, non mi pare comodo privarsene.
Michele






-----Original Message-----
From: plone-it-bounces a lists.plone.org [mailto:plone-it-bounces a lists.plone.org] On Behalf Of SauZheR at gOOgle
Sent: Thursday, July 26, 2007 9:29 AM
To: La lista degli italiani appassionati di Plone.
Subject: Re: [Plone-IT] Cattive nuove da fsrefs.py?


Sai una cosa bella strana?

Ho lanciato fsrefs sul mio data.fs bello pienotto e ha vomitato tutta quella roba di cui tu parli.
Allora ho creato una istanza zope bella nuova e pulita...
Zope 2.9.7 python 2.4.4, directory Products vuota. 
Faccio creare il data.fs lanciando l'istanza; poi la stoppo e lancio il fsrefs sul Data.fs che piu' lindo non si puo'

Ho ugualmente caterve di errori di refers to an invalid object.

che succede? 

sau.





Il 21/07/07, Zanotti Michele <Michele.Zanotti a apss.tn.it> ha scritto: 
Ciao a tutti,
Dopo lunghe prove ho aggiornato il mio sito di produzione da Zope
2.8.5/Plone 2.1.4 a zope 2.9.7/Plone 2.5.3 e poi PloneExFile da 3.2 a 4.
Tutto sembra essere andato bene, ho fatto alcuni test di uso e
funzionano, la routine che mi conta i file utilizzando il catalog ne
conta quanti ne sono nel filesystem (uso fss). Ho fatto un pack a zero 
giorni e ho lanciato fstest.py e non ha rilevato problemi. Poi ho
provato con fsref.py (routine che non usavo da tanto) e ottengo
quintalate di messaggi del tipo:

oid 0x2L OFS.Application.Application
last updated: 2007-07-21 11:59: 27.011000, tid=0x36F230F733F3700L
refers to invalid objects:
        oid ('\x00\x00\x00\x00\x00\x01\x08&', None) missing: '<unknown>'
        oid ('\x00\x00\x00\x00\x00\x00\x8f\xb3', None) missing: 
'<unknown>'
        oid ('\x00\x00\x00\x00\x00\x00\x8f\xb5', None) missing:
'<unknown>'
        oid ('\x00\x00\x00\x00\x00\x01\x0f\xfd', None) missing:
'<unknown>' 
        oid ('\x00\x00\x00\x00\x00\x02\xfa\x0b', None) missing:
'<unknown>'
        oid ('\x00\x00\x00\x00\x00\x04b\x90', None) missing: '<unknown>'
.....
oid 0x8BFE9L OFS.Image.Pdata
last updated: 2007-03-12 11:27:18.742000, tid=0x36C36CF4FF74311L
refers to invalid object:
        oid ('\x00\x00\x00\x00\x00\x08\xbf\xe8', None) missing:
'<unknown>'
..... 

Devo preoccuparmi?
Grazie
Michele


_______________________________________________
Plone-IT mailing list
Plone-IT a lists.plone.org
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html




-- 
  bye 
SauZheR
************************************
l'iterazione è umana...
la ricorsione, Divina!
************************************
reply to: sauzher AT gmail DOT com 




Maggiori informazioni sulla lista Plone-IT