[Plone-IT] Plone e Javascript

Riccardo Lemmi riccardo a reflab.it
Mer 25 Lug 2007 13:59:23 UTC


On Wednesday 25 July 2007 15:48, D4rkDev wrote:
> Salve, io ho la versione 2.5.3, ed ho lo stesso problema, vorrei inserire
> del codice javascript nei post che creo, ma appena pubblico la pagina il
> codice mi viene tagliato.

Il motivo per cui non  possibile fare questa operazione  un motivo di 
sicurezza, si cerca di evitare che in una community i 'member' siano in grado 
di inserire javascript o activeX potenzialmente pericolosi per gli altri 
utenti.  chiaro che nel caso di un sito in cui i redattori siano persone 
conosciute il problema  molto limitato.

Plone quando renderizza alcuni contenuti li passa attraverso una serie di 
filtri che sono gestiti da portal_transformer, in particolare safe_html si 
preoccupa di cancellare 'script' e 'object', basta quindi disattivarlo.

> Inoltre non trovo l'oggetto plone_javascript nella root,  un'ogetto
> esterno oppure lo trovo nella configurazione del portale?
> Grazie
> Ciao

portal_javascript e portal_transformer sono accedibili da ZMI:
http://<host:port>/<siteid>/manage

Ma portal_javascript non fa al caso tuo in quanto gestisce il codice 
javascript valido su tutto il portale (ad esempio quello del live search).
-- 
Riccardo Lemmi                           Email:   riccardo a reflab.it
Reflab S.r.l. - Plone Design, Development and Consulting
Phone: +39 349 4620820                         http://www.reflab.it
-------------- parte successiva --------------
Un allegato non testuale  stato rimosso....
Nome:        non disponibile
Tipo:        application/pgp-signature
Dimensione:  191 bytes
Descrizione: non disponibile
URL:         <http://lists.plone.org/pipermail/plone-plone-it/attachments/20070725/07f76de6/attachment.asc>


Maggiori informazioni sulla lista Plone-IT