[Plone-conosur] urgente! problemas con arquetipo

mai mmartinezaa en yahoo.com.ar
Mar Sep 17 09:08:42 UTC 2013


igual no funciona...me sigue pasando esto que muestro en la imagen. EN lugar de subirlo al sitio me da la opcion de descargar...es algo raro...no estará mal el codigo de mi arquetipo? ahi se los dejo...

RecepcionFile_schema = getattr(ATFile, 'schema', atapi.Schema(())).copy() + atapi.Schema((
      FileField('fileR',
              required=True,
              searchable=True,
              languageIndependent=True,
              storage=AnnotationStorage(migrate=True),
              validators=(('isNonEmptyFile', V_REQUIRED),
                          ('checkFileMaxSize', V_REQUIRED)),
              widget=FileWidget(
                        description='',
                        label=_(u'label_file', default=u'File'),
                        show_content_type=False,)),
    ), 
   )



class RecepcionFile(ATFile): 
    implements(interfaces.IRFile)
    security = ClassSecurityInfo()
    schema = RecepcionFile_schema
    schema["file"].required=False
    schema["file"].widget.visible={'edit':'hidden', 'view':'hidden'}
   

# Content type registration for the Archetypes machinery
registerType(RecepcionFile, config.PROJECTNAME)

 
Saludos 
------------ próxima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: <http://lists.plone.org/pipermail/plone-plone-conosur/attachments/20130917/731f4bf9/attachment-0001.html>


Más información sobre la lista de distribución Plone-ConoSur