[PLIP-Advisories] Re: [Plone] #9310: User registration process more flexible

plip-advisories at lists.plone.org plip-advisories at lists.plone.org
Mon Oct 19 21:49:33 UTC 2009


#9310: User registration process more flexible
---------------------+------------------------------------------------------
 Reporter:  dokter   |        Owner:  dokter
     Type:  PLIP     |       Status:  closed
 Priority:  minor    |    Milestone:  4.0   
Component:  Unknown  |   Resolution:  fixed 
 Keywords:           |  
---------------------+------------------------------------------------------

Comment(by maurits):

 I get several failures like the next because home page and location are
 not on the join form by default anymore.  Perhaps this worked on the
 branch but not after merging to trunk?   Could this have something to do
 with the new Plone theme?

 {{{
 $ bin/instance test -s plone.app.users
 ...
 File "/home/maurits/buildout/plone-
 coredev/4.0/src/plone.app.users/plone/app/users/tests/flexible_user_registration.txt",
 line 10, in flexible_user_registration.txt
 Failed example:
     form.getControl(name='form.location')
 Exception raised:
     Traceback (most recent call last):
       File "/home/maurits/shared-
 eggs/zope.testing-3.7.7-py2.6.egg/zope/testing/doctest.py", line 1361, in
 __run
         compileflags, 1) in test.globs
       File "<doctest flexible_user_registration.txt[line 10, example 3]>",
 line 1, in <module>
         form.getControl(name='form.location')
       File "/home/maurits/shared-
 eggs/zope.testbrowser-3.6.0a2-py2.6.egg/zope/testbrowser/browser.py", line
 755, in getControl
         control, form = disambiguate(intermediate, msg, index)
       File "/home/maurits/shared-
 eggs/zope.testbrowser-3.6.0a2-py2.6.egg/zope/testbrowser/browser.py", line
 54, in disambiguate
         raise LookupError(msg)
     LookupError: name 'form.location'

 }}}

 I am trying to integrate this plip with plip #9214 (see ticket #9643) and
 having successful tests before I start would be nice.
 This is with r30654.  I did some test and pep8/pyflakes fixes after that
 which did not result in extra test failures.  And I have begun integrating
 that plip anyway.  Sorry if I step on anyone's foot. :)

-- 
Ticket URL: <http://dev.plone.org/plone/ticket/9310#comment:48>
Plone <http://plone.org>
Plone Content Management System


More information about the PLIP-Advisories mailing list