[Framework-Team] Re: Plone 4 dependencies

Raphael Ritz r.ritz at biologie.hu-berlin.de
Tue May 26 09:33:08 UTC 2009


Wichert Akkerman wrote:
> I seem to remember the plan was to target Plone 4 for CMF 2.2 and Zope
> 2.11, but as you can see below that does not appear to be possible.

So that means Zope 2.12 instead, right?

Do we have an estimate of what that implies on our side?

Generally speaking, I'm a bit uncomfortable with jumping
from Zope 2.10.x to 2.12.x as this will reduce the chances
of reacting to deprecation warnings which is of particular
importance for all our add-on developers. I'm afraid we'll
see lots of broken add-ons without prior warnings.

If there is nothing we can do about this (and it seems so)
we could still consider to have Plone 3.x move to Zope 2.11
with 3.4 or 3.5.

Just thinking out loud (and without knowing myself how much
differences there are between Zope 2.10 and 12 that do affect
us) ...

Raphael


> 
> Wichert.
> 
> 
> ----- Forwarded message from Jens Vagelpohl <jens at dataflake.org> -----
> 
> From: Jens Vagelpohl <jens at dataflake.org>
> To: Zope-CMF List <zope-cmf at zope.org>
> Subject: Re: [Zope-CMF] Zope dependency
> Message-Id: <7D23DF64-B4DC-4C8E-8A51-188E8B34AA7B at dataflake.org>
> Date: Tue, 26 May 2009 10:57:08 +0200
> X-Spam-Status: No, score=-1.2 required=5.0 tests=AWL,BAYES_00,
> 	RCVD_IN_DNSWL_LOW autolearn=ham version=3.2.3
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> On May 26, 2009, at 10:21 , Wichert Akkerman wrote:
> 
>> Previously Jens Vagelpohl wrote:
>>> The CMF eggs, even on trunk, still advertise compatibility with Zope
>>> 2.10. I believe we had agreed to target Zope 2.12 with trunk - please
>>> correct me if that's wrong. If we do want Zope 2.12 I would like to  
>>> go
>>> through before the first CMF 2.2 beta and do the following:
>>>
>>>  - adjust all setup.py files to show the Zope2 egg as dependency,
>>> which will imply the "Zope2 >= 2.12dev" dependency
>>>
>>>  - go through and delete all BBB code for Zope versions earlier than
>>> 2.12
>>>
>>> If anyone thinks that's a bad idea please speak up.
>> I think we are targetting Plone 4 at CMF 2.2 and Zope 2.11 at the
>> moment, so that would be bad for us.
> 
> I'm guessing you are not aware that there already is a hard dependency  
> in CMFDefault. In essence, I would not be setting a new policy, I  
> would document the current situation.
> 
> jens
> 
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
> 
> iEYEARECAAYFAkobruQACgkQRAx5nvEhZLJadACfa9oLhpOAluaPN4QNqGf8UW26
> 4V8AmwSNnABEZwAQwpq1XddErphVHW0o
> =o1v4
> -----END PGP SIGNATURE-----
> _______________________________________________
> Zope-CMF maillist  -  Zope-CMF at lists.zope.org
> http://mail.zope.org/mailman/listinfo/zope-cmf
> 
> See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests
> 
> ----- End forwarded message -----
> 





More information about the Framework-Team mailing list