[Framework-Team] 3.0 bundle broken?

Raphael Ritz r.ritz at biologie.hu-berlin.de
Wed Nov 22 08:52:12 UTC 2006


Alexander Limi schrieb:
> When doing SVN update and trying to start the 3.0 bundle, I get the 
> following. A new documented dependency, or is it GS/Five changing under 
> us? :)

[..]

> Products.GenericSetup.interfaces.IBody>, '')
>     File 
> "/Volumes/Work/Users/limi/Projects/Plone/3.0/lib/python/plone/app/portlets/exportimport/configure.zcml", 
> line 4.2-4.52
>         <adapter factory=".portlets.PortletsXMLAdapter" />
>     File 
> "/Volumes/Work/Users/limi/Projects/Plone/3.0/Products/GenericSetup/configure.zcml", 
> line 55.2-57.8
>         <adapter
>             factory=".components.ComponentRegistryXMLAdapter"
>             />

Same happend to me last night and I was too tired to debug this :-(

Also, be it for this or any other reason, I couldn't get the wicked
nor the iterate bundle to start up which I had planed to take a closer
look at.

It seems to me that there might be something wrong with our process
leading to a substancial waste of time due to the fact that we usually
link to moving targets (aka trunk) in our review bundles.
Maybe we should recommend to specify at least a revision number when
linking to trunk versions of dependencies or anything else that
would lead to a better defined and more stable state?

Raphael





More information about the Framework-Team mailing list