[Framework-Team] 3.0 bundle broken?

Alexander Limi limi at plone.org
Wed Nov 22 03:38:17 UTC 2006


When doing SVN update and trying to start the 3.0 bundle, I get the  
following. A new documented dependency, or is it GS/Five changing under  
us? :)

2006-11-21 19:36:26 ERROR Application Couldn't install Five
Traceback (most recent call last):
   File "/Users/limi/Projects/Zope/2.10/lib/python/OFS/Application.py",  
line 780, in install_product
     initmethod(context)
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/Products/Five/__init__.py",  
line 31, in initialize
     zcml.load_site()
   File "/Users/limi/Projects/Zope/2.10/lib/python/Products/Five/zcml.py",  
line 53, in load_site
     _context = xmlconfig.file(file)
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/zope/configuration/xmlconfig.py",  
line 581, in file
     context.execute_actions()
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/zope/configuration/config.py",  
line 606, in execute_actions
     for action in resolveConflicts(self.actions):
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/zope/configuration/config.py",  
line 1513, in resolveConflicts
     raise ConfigurationConflictError(conflicts)
ConfigurationConflictError: Conflicting configuration actions
   For: ('adapter', (<InterfaceClass  
zope.component.interfaces.IComponentRegistry>, <InterfaceClass  
Products.GenericSetup.interfaces.ISetupEnviron>), <InterfaceClass  
Products.GenericSetup.interfaces.IBody>, '')
     File  
"/Volumes/Work/Users/limi/Projects/Plone/3.0/lib/python/plone/app/portlets/exportimport/configure.zcml",  
line 4.2-4.52
         <adapter factory=".portlets.PortletsXMLAdapter" />
     File  
"/Volumes/Work/Users/limi/Projects/Plone/3.0/Products/GenericSetup/configure.zcml",  
line 55.2-57.8
         <adapter
             factory=".components.ComponentRegistryXMLAdapter"
             />
Traceback (most recent call last):
   File  
"/Volumes/Work/Users/limi/Projects/Zope/2.10/lib/python/Zope2/Startup/run.py",  
line 56, in ?
     run()
   File  
"/Volumes/Work/Users/limi/Projects/Zope/2.10/lib/python/Zope2/Startup/run.py",  
line 21, in run
     starter.prepare()
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/Zope2/Startup/__init__.py",  
line 102, in prepare
     self.startZope()
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/Zope2/Startup/__init__.py",  
line 278, in startZope
     Zope2.startup()
   File "/Users/limi/Projects/Zope/2.10/lib/python/Zope2/__init__.py", line  
47, in startup
     _startup()
   File "/Users/limi/Projects/Zope/2.10/lib/python/Zope2/App/startup.py",  
line 102, in startup
     OFS.Application.initialize(application)
   File "/Users/limi/Projects/Zope/2.10/lib/python/OFS/Application.py",  
line 309, in initialize
     initializer.initialize()
   File "/Users/limi/Projects/Zope/2.10/lib/python/OFS/Application.py",  
line 338, in initialize
     self.install_products()
   File "/Users/limi/Projects/Zope/2.10/lib/python/OFS/Application.py",  
line 603, in install_products
     return install_products(app)
   File "/Users/limi/Projects/Zope/2.10/lib/python/OFS/Application.py",  
line 634, in install_products
     folder_permissions, raise_exc=debug_mode)
   File "/Users/limi/Projects/Zope/2.10/lib/python/OFS/Application.py",  
line 780, in install_product
     initmethod(context)
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/Products/Five/__init__.py",  
line 31, in initialize
     zcml.load_site()
   File "/Users/limi/Projects/Zope/2.10/lib/python/Products/Five/zcml.py",  
line 53, in load_site
     _context = xmlconfig.file(file)
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/zope/configuration/xmlconfig.py",  
line 581, in file
     context.execute_actions()
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/zope/configuration/config.py",  
line 606, in execute_actions
     for action in resolveConflicts(self.actions):
   File  
"/Users/limi/Projects/Zope/2.10/lib/python/zope/configuration/config.py",  
line 1513, in resolveConflicts
     raise ConfigurationConflictError(conflicts)
zope.configuration.config.ConfigurationConflictError: Conflicting  
configuration actions
   For: ('adapter', (<InterfaceClass  
zope.component.interfaces.IComponentRegistry>, <InterfaceClass  
Products.GenericSetup.interfaces.ISetupEnviron>), <InterfaceClass  
Products.GenericSetup.interfaces.IBody>, '')
     File  
"/Volumes/Work/Users/limi/Projects/Plone/3.0/lib/python/plone/app/portlets/exportimport/configure.zcml",  
line 4.2-4.52
         <adapter factory=".portlets.PortletsXMLAdapter" />
     File  
"/Volumes/Work/Users/limi/Projects/Plone/3.0/Products/GenericSetup/configure.zcml",  
line 55.2-57.8
         <adapter
             factory=".components.ComponentRegistryXMLAdapter"
             />

-- 
_____________________________________________________________________

      Alexander Limi · Chief Architect · Plone Solutions · Norway

  Consulting · Training · Development · http://www.plonesolutions.com
_____________________________________________________________________

       Plone Co-Founder · http://plone.org · Connecting Content
   Plone Foundation · http://plone.org/foundation · Protecting Plone
 





More information about the Framework-Team mailing list