[Framework-Team] plone.app.* or plone.* for things with Z2, CMF and Archetypes dependencies?
optilude at gmx.net
Mon Dec 11 14:54:21 UTC 2006
On 12/11/06, Wichert Akkerman <wichert at wiggy.net> wrote:
> Previously Martin Aspeli wrote:
> > Daniel pointed out that it's a bit odd for Archetypes to depend on
> > plone.app (Plone-the-application) and really, plone.app.locking is not
> > Plone app specific. It is also not "pure Zope 3", though.
> Is the Zope 2 dependency an implementation detail or as an inherint part
> of its design?
Well, it basically provides the default adapter for ILocakble that
implements locks using webdav.LockItem, which is part of Zope 2.
It also needs getSecurityManager().getUser() in a couple of places,
since locks are keyed on user.
> > What is the best naming convention in this case? Should plone.app.* be
> > only for Plone-the-application specific things, and thus plone.* is
> > allowed to have Zope 2, CMF and/or Archetypes dependencies (with an
> > aim to minimise, obviously)? Or should we have another package,
> > plone.z2 or something? Or should we just let plone.app.* mean
> > Zope2-specific rather than Plone-the-application specific?
> I'ld say plone.app.* means Plone-the-application specific. I don't have
> any problems with dependencies in plone.*. Every python package will
> have some dependency, and often dependencies are just implementation
> details which can change over time.
Okay, so plone.locking is better than plone.app.locking?
+1 to that
More information about the Framework-Team